Dove sono

Contattami

Address

Abito da qualche parte su questa minuscola sfera nuvolosa. In un pezzo di terra e rocce a forma di stivale, dove l'abitante medio è il furbetto che si lamenta se gli altri fanno i furbetti.

Riparazione alimentatore PowerMac G4

Riparazione alimentatore PowerMac G4
Apr
18

 

Qualche giorno fa mi è capitato di dover smaltire un powermac G4, un vecchio catorcio di quasi dodici anni. Il computer in questione aveva qualche noto problema di alimentazione (curiosamente non si accendeva), e stando a quello che ha detto l’(ex) proprietario c’era da spenderci più di quello che valeva.
Tentare non nuoce, me lo sono portato in laboratorio e ci ho dato una occhiata.

Il modello in questione è un PowerMac G4 “Mirrored Drive Doors” (MDD) del 2002

PowerMacG4Tenuto molto bene, completo di tutto (tranne il secondo SD), perfetto sotto ogni aspetto. Lo smonto e noto che effettivamente sembra funzionare bene…. qualche volta. La spia si accende quando viene premuto il pulsante, ma niente altro. Ogni tanto parte, fa il consueto suono e si avvia come nulla fosse. Provando a misurare le tensioni dal cavo di alimentazione noto con piacere che la tensione di trickle (o di avviamento) è presente, ma arriva a pochi milliampere nel caso venga applicata una piccola resistenza. Fin qua potrebbe anche starci, il problema si nota quando mettendo a massa il filo che segnala l’accensione l’alimentatore non si muove. Eppure se ogni tanto funziona deve essere per forza un problema di avvio, niente di eccessivamente grave.

Smonto l’alimentatore, pieno di “gatti” di polvere da essersi intasato, con i fili che fanno un giro assurdo all’interno del case… apro il tutto e mi ritrovo un comune switching, con apparentemente nessun segno di bruciature. Fusibile OK, nessun condensatore scoppiato, niente di nero… cerco di capire come è posizionato il circuito che pilota il tutto.

All’uscita c’è una scheda montata in verticale che dovrebbe controllare le tensioni e l’accensione, e verso l’oscillatore di potenza ne è presente un’altra. Un ottimo posto per cuocere dei condensatori. Dopo un breve test su alcuni componenti del circuito finale e sui diodi (con scarsi successi) decido di dissaldare tutto il dissipatore con i transistor di potenza attaccati per controllare sotto.
Ce ne è voluto di tempo, ma è venuto comunque un buon risultato; non so se è multistrato, ma non è esageratamente complicato, bisogna fare comunque attenzione a pulire il tutto con la calza dissaldante prima di rimontare il blocco, altrimenti alcuni pin non passano.

 

Sotto erano presenti tre condensatori, dopo il test ho notato che mancava qualche microfarad al valore totale di alcuni, per sicurezza li ho cambiati tutti. Non avevo quelli uguali, ne ho messi due da 100uF invece che 56uF e ho cambiato quello da 47uF con uno uguale. Non è facile farci stare condensatori più grandi, devono essere uguali.

 

I tre condensatori erano marcati: C135, C137, C141

 

Cambiarli mi è costato molto meno che un alimentatore nuovo su ebay! E a quanto leggo sembra che si tratti di una serie difettosa, di MDD ne ho visti tanti con questo problema, ma non ci ho mai badato più di tanto.

 

Dopo aver rimontato il blocco di integrati con il dissipatore ho subito fatto una prova: e invece del consueto botto che mi è già capitato con altri G4, mi è saltata la luce.
Ah, dannazione! Il filo di terra era in corto sotto la scheda. Secondo tentativo e tutto ha funzionato, il computer si avvia ad ogni tentativo. Collaudato per diverse settimane, senza aver notato ulteriori problemi. L’unica differenza è uno strano ronzio che fa prima di andare in standby. Nient’altro.

 

Nonostante tutti gli anni che si porta rimane una macchina rispettabile. Non carica i video in flash, ma come computer da laboratorio è perfetto. C’era allegato pure il suo ADC Cinema Display, che pur funzionando aveva la spia che continuava a lampeggiare. Il manuale dice che è un problema relativo all’inverter. Provandolo con dei pezzi di un altro schermo uguale.. ho notato che andavano cambiate le lampade. Ma non l’LCD.

 

Per un lavoro simile va smontato pezzo per pezzo… facendo attenzione che non entri polvere tra il backlight e l’LCD! Se lo apro ci va sicuramente della polvere. Tentai di aprirlo da dietro, facendo in modo di non staccare l’LCD dagli strati che componevano il backlight, e la cosa riuscì. Dopo il cambio delle lampade la spia non lampeggiava più.
Che dire? C’è da divertirsi! Questo computer abbinato alle sue casse ha un audio spettacolare.

PowerMac_Workstation

Comments (4)

ciao, ho un powermac G4 del 2003 che uso come muletto. E’ stato spento parecchio tempo e da qualche giorno al tentativo di avviarlo tramite pulsante, parte fa il solito boing, ma dopo circa 20 secondi si spegne. Ai successivi tentativi di accensione la durata è sempre minore fino a zero. Se ritento dopo qualche ora (presumo a freddo) dura ancora 20 secondi e via dicendo… Il computer è buono, l’hard disk è ok e tutti i dati sono all’interno, mi spiace rottamarlo per un difetto del genere…sai dirmi cosa può essere, se vale la pena ripararlo ed eventualmente chi è in grado di farlo con poca spesa?
Grazie mille, ciao.
Francesco

Sembra un problema di surriscaldamento, controlla che non sia intasato di polvere, usa dell’aria compressa per pulirlo (vai all’aperto) e riprova. Potrebbe essere il sistema che va in crash, altrimenti è una insufficienza di alimentazione, la cosa migliore sarebbe provare con un computer uguale a cercare di cambiare man mano le parti per trovare quella guasta.

ok grazie, proverò a pulirlo. Ho sostituito anche la pila da 3.6 V e resettato la PMU ma, come tu dici, credo sia un problema legato al surriscaldamento di qualcosa o comunque legato all’alimentazione. Sono un profano di elettronica ma sembrerebbe qualche componente che non sopporta più la tensione. Vedremo, grazie ancora.

provato a pulirlo, niente…morituri te salutant, bisognerebbe trovare uno bravo in elettronica ;)

Leave a Comment